|
FSTAB(5) FreeBSD File Formats Manual FSTAB(5)
NAME
fstab -- static information about the file systems
SYNOPSIS
#include
DESCRIPTION
The file fstab contains descriptive information about the various file
systems. fstab is only read by programs, and not written; it is the duty
of the system administrator to properly create and maintain this file.
Each file system is described on a separate line; fields on each line are
separated by tabs or spaces. The order of records in fstab is important
because fsck(8), mount(8), and umount(8) sequentially iterate through
fstab doing their thing.
The first field, (fs_spec), describes the block special device or remote
file system to be mounted. For file systems of type ufs, the special
file name is the block special file name, and not the character special
file name. If a program needs the character special file name, the pro-
gram must create it by appending a ``r'' after the last ``/'' in the spe-
cial file name.
The second field, (fs_file), describes the mount point for the file sys-
tem. For swap partitions, this field should be specified as ``none''.
The third field, (fs_vfstype), describes the type of the file system.
The system can support various file system types. Only the root, /usr,
and /tmp file systems need be statically compiled into the kernel; every-
thing else will be automatically loaded at mount time. (Exception: the
UFS family - FFS and LFS cannot currently be demand-loaded.) Some people
still prefer to statically compile other file systems as well.
The fourth field, (fs_mntops), describes the mount options associated
with the file system. It is formatted as a comma separated list of
options. It contains at least the type of mount (see fs_type below) plus
any additional options appropriate to the file system type. See the
options flag (-o) in the mount(8) page and the file system specific page,
such as mount_nfs(8), for additional options that may be specified.
If the options ``userquota'' and/or ``groupquota'' are specified, the
file system is automatically processed by the quotacheck(8) command, and
user and/or group disk quotas are enabled with quotaon(8). By default,
file system quotas are maintained in files named quota.user and
quota.group which are located at the root of the associated file system.
These defaults may be overridden by putting an equal sign and an alterna-
tive absolute pathname following the quota option. Thus, if the user
quota file for /tmp is stored in /var/quotas/tmp.user, this location can
be specified as:
userquota=/var/quotas/tmp.user
If the option ``noauto'' is specified, the file system will not be auto-
matically mounted at system startup. Note that, for network file systems
of third party types (i.e., types supported by additional software not
included in the base system) to be automatically mounted at system
startup, the extra_netfs_types rc.conf(5) variable must be used to extend
the rc(8) startup script's list of network file system types.
The type of the mount is extracted from the fs_mntops field and stored
separately in the fs_type field (it is not deleted from the fs_mntops
field). If fs_type is ``rw'' or ``ro'' then the file system whose name
is given in the fs_file field is normally mounted read-write or read-only
on the specified special file. If fs_type is ``sw'' then the special
file is made available as a piece of swap space by the swapon(8) command
at the end of the system reboot procedure. The fields other than fs_spec
and fs_type are unused. If fs_type is specified as ``xx'' the entry is
ignored. This is useful to show disk partitions which are currently
unused.
The fifth field, (fs_freq), is used for these file systems by the dump(8)
command to determine which file systems need to be dumped. If the fifth
field is not present, a value of zero is returned and dump will assume
that the file system does not need to be dumped.
The sixth field, (fs_passno), is used by the fsck(8) program to determine
the order in which file system checks are done at reboot time. The root
file system should be specified with a fs_passno of 1, and other file
systems should have a fs_passno of 2. File systems within a drive will
be checked sequentially, but file systems on different drives will be
checked at the same time to utilize parallelism available in the hard-
ware. If the sixth field is not present or is zero, a value of zero is
returned and fsck(8) will assume that the file system does not need to be
checked.
#define FSTAB_RW "rw" /* read/write device */
#define FSTAB_RQ "rq" /* read/write with quotas */
#define FSTAB_RO "ro" /* read-only device */
#define FSTAB_SW "sw" /* swap device */
#define FSTAB_XX "xx" /* ignore totally */
struct fstab {
char *fs_spec; /* block special device name */
char *fs_file; /* file system path prefix */
char *fs_vfstype; /* File system type, ufs, nfs */
char *fs_mntops; /* Mount options ala -o */
char *fs_type; /* FSTAB_* from fs_mntops */
int fs_freq; /* dump frequency, in days */
int fs_passno; /* pass number on parallel fsck */
};
The proper way to read records from fstab is to use the routines
getfsent(3), getfsspec(3), getfstype(3), and getfsfile(3).
FILES
/etc/fstab The file fstab resides in /etc.
SEE ALSO
getfsent(3), getvfsbyname(3), dump(8), fsck(8), mount(8), quotacheck(8),
quotaon(8), swapon(8), umount(8)
HISTORY
The fstab file format appeared in 4.0BSD.
FreeBSD 6.1 June 5, 1993 FreeBSD 6.1
|